Setup CentOS 6.4 to run PHP 5.5

I always use the PHP mysql native driver aka mysqlnd when I develop something serious in PHP. Because of many reasons, both of performance and software design nature.

I’ve learned the hard way that the trio mysqlnd – CentOS 6 – PHP 5.3 is never a happy story, unless you have a system administrator sitting around to compile PHP 5.3 with the mysqlnd option in configure command every time you setup another web server. I don’t want to go further to other implications, to be honest I hate being logged in as root and I try to make my visits as short as possible. Sometimes I wonder how sysadmins can like their job.

So, I took a leap of faith, I upgraded all my servers to CentOS 6.4 and I installed PHP 5.5 which ships with mysqlnd and did all the management with yum. Sweet.

It is a bit trickier than it seems though. The default PHP that ships with CentOS 6.4 is PHP 5.3.

Continue reading Setup CentOS 6.4 to run PHP 5.5